Latest 0.1.5
Homepage https://github.com/AttilaTheFun/OAuthService
License MIT
Platforms ios 8.0, requires ARC
Authors

[![CI Status](http://img.shields.io/travis/Logan Shire/OAuthService.svg?style=flat)](https://travis-ci.org/Logan Shire/OAuthService)
Version
License
Platform

Usage

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

OAuthService is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "OAuthService"

Author

Logan Shire, [email protected]

License

OAuthService is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "OAuthService",
    "version": "0.1.5",
    "summary": "A simple dependency-injectable wrapper around the OAuthSwift library.",
    "description": "A simple dependency-injectable wrapper around the OAuthSwift library.nA member of the Trellis family of services.",
    "homepage": "https://github.com/AttilaTheFun/OAuthService",
    "license": "MIT",
    "authors": {
        "Logan Shire": "[email protected]"
    },
    "source": {
        "git": "https://github.com/AttilaTheFun/OAuthService.git",
        "tag": "0.1.5"
    },
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "subspecs": [
        {
            "name": "API",
            "dependencies": {
                "SwiftToolKit": [
                    "~>0.2.4"
                ],
                "ServiceRegistry/API": [
                    "~>0.3.0"
                ],
                "PromiseKit": [
                    "~>3.0"
                ]
            },
            "source_files": "Pod/API/*.swift"
        },
        {
            "name": "Implementation",
            "dependencies": {
                "OAuthService/API": [],
                "OAuthSwift": [
                    "~>0.4.8"
                ]
            },
            "source_files": "Pod/Implementation/*.swift"
        },
        {
            "name": "Test",
            "dependencies": {
                "ServiceRegistry": [
                    "~>0.3.0"
                ]
            }
        }
    ]
}

Pin It on Pinterest

Share This