Latest 0.2.0
Homepage https://github.com/guakeliao/LwScanningByZxing
License MIT
Platforms ios 7.0, requires ARC
Dependencies ZXingObjC
Authors

CI Status
Version
License
Platform

Usage

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

LwScanningByZxing is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "LwScanningByZxing"

HOW TO USE

  • LwScanView 扫描二维码

    1.用ZXing做的二维码扫面View,支持自定义扫描图层

    2.用法:

    • 支持用xib,直接将一个View改变成LwScanView,在VC中加入回调代码即可:

          //扫描二维码
           self.scanVIew.callBack = ^(id data) {
              //data即扫描得到的字符串
               NSLog(@"hello:%@", data);
          };
    • UIViewController+Recognize 相册识别二维码

      1.用ZXing做的二维码识别VC

    2.用法:

    • 在你的VC中,引入类别UIViewController+Recognize即可,加入回调代码:

       //识别二维码
       [self recognizeImage:^(id string) {
            NSLog(@"%@", string);
      }];
    • LwCreateView 生成二维码

      1.。。。

    2.用法:

    • 支持Xib,将一个View改变车让那个LwCreateView,在VC中加入执行回调代码即可:

       [self.createView createImage:CGSizeMake(1080, 1080)
                          successBlock:^(id image) {
                          self.imageView.image = image;
                      }];

Author

liaowei, [email protected]

License

LwScanningByZxing is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "LwScanningByZxing",
    "version": "0.2.0",
    "summary": "u96c6u6210u4e8cu7ef4u7801u76f8u5173u529fu80fd:u626bu63cf.u8bc6u522b.u751fu6210",
    "description": "u96c6u6210u4e8cu7ef4u7801u76f8u5173u529fu80fd:u626bu63cf,u8bc6u522b,u751fu6210.u91c7u7528ZXing",
    "homepage": "https://github.com/guakeliao/LwScanningByZxing",
    "license": "MIT",
    "authors": {
        "guakeliao": "[email protected]"
    },
    "source": {
        "git": "https://github.com/guakeliao/LwScanningByZxing.git",
        "tag": "0.2.0"
    },
    "platforms": {
        "ios": "7.0"
    },
    "requires_arc": true,
    "source_files": "Pod/Classes/**/*",
    "resources": "Pod/Assets/**/*",
    "dependencies": {
        "ZXingObjC": [
            "~> 3.1.0"
        ]
    }
}

Pin It on Pinterest

Share This