Latest 1.0.4
Homepage https://github.com/Friend-LGA/LGConnection
License MIT
Platforms ios 6.0, requires ARC
Dependencies AFNetworking, Reachability, XMLReader-Arc, LGHelper
Authors

iOS wrapper around AFNetworking makes it easy to use.

Installation

With source code

With CocoaPods

CocoaPods is a dependency manager for Objective-C, which automates and simplifies the process of using 3rd-party libraries in your projects. See the "Get Started" section for more details.

Podfile

platform :ios, '6.0'
pod 'LGConnection', '~> 1.0.0'

Usage

In the source files where you need to use the library, import the header file:

#import "LGConnection.h"

Initialization

You have several methods for initialization:

- (instancetype)initWithRepeatAfterConnectionLost:(BOOL)repeat;

- (instancetype)initWithRepeatAfterConnectionLost:(BOOL)repeat
                            connectionLostHandler:(void(^)())connectionLostHandler
                         connectionRestoreHandler:(void(^)())connectionRestoreHandler;

LGConnection use Reachability to watch for internet connection. "RepeatAfterConnectionLost" means that if connection is lost, then all requests will try to reconnect while connection is restoring.

More

For more details see LGConnection.h

License

LGConnection is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "LGConnection",
    "version": "1.0.4",
    "platforms": {
        "ios": "6.0"
    },
    "license": "MIT",
    "homepage": "https://github.com/Friend-LGA/LGConnection",
    "authors": {
        "Grigory Lutkov": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Friend-LGA/LGConnection.git",
        "tag": "1.0.4"
    },
    "summary": "iOS wrapper around AFNetworking makes it easy to use",
    "requires_arc": true,
    "source_files": "LGConnection/*.{h,m}",
    "dependencies": {
        "AFNetworking": [
            "~> 2.5.0"
        ],
        "Reachability": [
            "~> 3.2"
        ],
        "XMLReader-Arc": [
            "~> 1.1"
        ],
        "LGHelper": [
            "~> 1.1.0"
        ]
    }
}

Pin It on Pinterest

Share This