Latest 6.0.0
Homepage https://github.com/jessesquires/JSQWebViewController
License MIT
Platforms ios 8.0, requires ARC
Frameworks WebKit

No Maintenance Intended

NOTE: As of iOS 9, this library is no longer necessary.

You should use SFSafariViewController instead.

⚠ Deprecated ⚠

Build Status Version Status license MIT codecov Carthage compatible Platform

A lightweight Swift WebKit view controller for iOS

screenshot
      
screenshot

Requirements

  • Swift 3.2+
  • Xcode 9+
  • iOS 8+

Installation

CocoaPods (recommended)

use_frameworks!

# For latest release in cocoapods
pod 'JSQWebViewController'

Carthage

github "jessesquires/JSQWebViewController"

Documentation

Read the docs. Generated with jazzy. Hosted by GitHub Pages.

Generate

$ ./build_docs.sh

Preview

$ open index.html -a Safari

Getting Started

import JSQWebViewController

let controller = WebViewController(url: URL(string: "http://jessesquires.com")!)
let nav = UINavigationController(rootViewController: controller)
present(nav, animated: true, completion: nil)

See the included example app, open Example/Example.xcodeproj.

Contribute

Please follow these sweet contribution guidelines.

Credits

Created and maintained by @jesse_squires.

License

JSQWebViewController is released under an MIT License. See LICENSE for details.

Copyright © 2015 Jesse Squires.

Please provide attribution, it is greatly appreciated.

Latest podspec

{
    "name": "JSQWebViewController",
    "version": "6.0.0",
    "license": "MIT",
    "summary": "A lightweight Swift WebKit view controller for iOS",
    "homepage": "https://github.com/jessesquires/JSQWebViewController",
    "documentation_url": "https://jessesquires.github.io/JSQWebViewController",
    "social_media_url": "https://twitter.com/jesse_squires",
    "authors": "Jesse Squires",
    "source": {
        "git": "https://github.com/jessesquires/JSQWebViewController.git",
        "tag": "6.0.0"
    },
    "source_files": "Source/*.swift",
    "platforms": {
        "ios": "8.0"
    },
    "frameworks": "WebKit",
    "requires_arc": true,
    "deprecated": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This