Latest 8.0.0
Homepage https://github.com/jessesquires/JSQCoreDataKit
License MIT
Platforms ios 11.0, osx 10.12, tvos 11.0, watchos 4.0, requires ARC
Frameworks CoreData

Build Status Version Status license MIT codecov Platform Carthage compatible

A swifter Core Data stack

About

This library aims to do the following:

  • Provide better interoperability with Swift
  • Harness Swift features and enforce Swift paradigms
  • Bring functional paradigms to Core Data
  • Make Core Data more Swifty
  • Simplify the processes of standing up the Core Data stack
  • Aid in testing your Core Data models
  • Reduce the boilerplate involved with Core Data

Further reading on Core Data:

Requirements

  • Xcode 10+
  • Swift 4.2+
  • iOS 11.0+
  • macOS 10.12+
  • tvOS 11.0+
  • watchOS 4.0+
  • SwiftLint

Installation

CocoaPods (recommended)

use_frameworks!

# Latest release in CocoaPods
pod 'JSQCoreDataKit'

# Latest on develop branch
pod 'JSQCoreDataKit', :git => 'https://github.com/jessesquires/JSQCoreDataKit.git', :branch => 'develop'

Carthage

github "jessesquires/JSQCoreDataKit"

Documentation

Read the docs. Generated with jazzy. Hosted by GitHub Pages.

Generate

$ ./scripts/build_docs.sh

Preview

$ open index.html -a Safari

Contribute

Please follow these sweet contribution guidelines.

Credits

Created and maintained by @jesse_squires.

License

JSQCoreDataKit is released under an MIT License. See LICENSE for details.

Copyright © 2015-present Jesse Squires.

Please provide attribution, it is greatly appreciated.

Latest podspec

{
    "name": "JSQCoreDataKit",
    "version": "8.0.0",
    "license": "MIT",
    "summary": "A swifter Core Data stack",
    "homepage": "https://github.com/jessesquires/JSQCoreDataKit",
    "documentation_url": "https://jessesquires.github.io/JSQCoreDataKit",
    "social_media_url": "https://twitter.com/jesse_squires",
    "authors": "Jesse Squires",
    "source": {
        "git": "https://github.com/jessesquires/JSQCoreDataKit.git",
        "tag": "8.0.0"
    },
    "source_files": "Source/*.swift",
    "swift_version": "4.2",
    "platforms": {
        "ios": "11.0",
        "osx": "10.12",
        "tvos": "11.0",
        "watchos": "4.0"
    },
    "frameworks": "CoreData",
    "requires_arc": true
}

Pin It on Pinterest

Share This