Latest 1.1
Homepage https://github.com/seanoshea/ios-etsy-sdk
License Apache 2
Platforms ios 7.0, requires ARC
Dependencies AFNetworking
Authors

Very simple read-only (no OAUTH) library to connect to a few Etsy services.

http://www.etsy.com/developers has all information for Etsy developers.

cocoa-pods

If you are downloading this library, execute the following from the bootstrap directory:

pod install

This should download AFNetworking and Kiwi. AFNetworking is used extensively in the project. Kiwi is simply used for unit testing the API calls.

travis-ci

Build Status

versions

1.0 (https://github.com/seanoshea/ios-etsy-sdk/tree/1.0) uploaded to CocoaPods
1.1 (https://github.com/seanoshea/ios-etsy-sdk/tree/1.1) iOS 7 only library.

Latest podspec

{
    "name": "ios-etsy-sdk",
    "version": "1.1",
    "license": {
        "type": "Apache 2",
        "file": "LICENSE"
    },
    "homepage": "https://github.com/seanoshea/ios-etsy-sdk",
    "summary": "Very simple read-only (no OAUTH) library to connect to a few Etsy services.",
    "authors": {
        "Sean O Shea": "[email protected]"
    },
    "source": {
        "git": "https://github.com/seanoshea/ios-etsy-sdk.git",
        "tag": "1.1"
    },
    "platforms": {
        "ios": "7.0"
    },
    "source_files": "ios-etsy-sdk",
    "requires_arc": true,
    "dependencies": {
        "AFNetworking": [
            "= 1.3.2"
        ]
    },
    "prefix_header_contents": "#import "SOSEtsyConstants.h""
}

Pin It on Pinterest

Share This