Latest 2.0.1
Homepage https://github.com/marcelo-schroeder/IFAHtml
License Apache-2.0
Platforms ios 10.0, requires ARC
Dependencies IFAAppUI
Authors

Carthage compatible
Cocoapods compatible
Version
Licence
Platform

IFAHtml is a Cocoa Touch framework for HTML parsing and manipulation. IFAHtml requires iOS 8 or greater.

Compatibility information:

IFAHtml version Xcode version iOS deployment target Swift version
1.x 8.x 9.0 3.2
2.x 9.x 10.0 4.0

This framework has been used in a few projects for my clients.

The latest API documentation can be found here.

Additional documentation and sample code are coming soon.

How to integrate IFAHtml

IFAHtml can be integrated to your project via Cocoapods or Carthage.

Latest API Documentation

http://cocoadocs.org/docsets/IFAHtml

3rd Party Credits

Latest podspec

{
    "name": "IFAHtml",
    "version": "2.0.1",
    "summary": "A Cocoa Touch framework for HTML parsing and manipulation.",
    "homepage": "https://github.com/marcelo-schroeder/IFAHtml",
    "license": "Apache-2.0",
    "authors": {
        "Marcelo Schroeder": "[email protected]"
    },
    "platforms": {
        "ios": "10.0"
    },
    "requires_arc": true,
    "source": {
        "git": "https://github.com/marcelo-schroeder/IFAHtml.git",
        "tag": "v2.0.1"
    },
    "source_files": "IFAHtml/IFAHtml/classes/**/*.{h,m}",
    "libraries": "xml2",
    "xcconfig": {
        "HEADER_SEARCH_PATHS": ""$(SDKROOT)/usr/include/libxml2""
    },
    "dependencies": {
        "IFAAppUI": [
            "~> 2.0"
        ]
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This