Latest 1.0.2
Homepage https://github.com/soundcloud/CocoaSoundCloudAPI
License Apache License, Version 2.0
Platforms ios
Dependencies NXOAuth2Client
Frameworks Security
Authors , , ,

Important notice

Unfortunately, we decided to discontinue support for this project; SoundCloud will no longer accept pull requests or make public releases of CocoaSoundCloudAPI. If you’re using CocoaSoundCloudAPI in one of your projects, we suggest you fork the project in order to perform any necessary maintenance.

The SoundCloud API for Cocoa

So you want to share your tracks in your iOS Application to SoundCloud? With this project you only need a few lines of code for doing that. The SoundCloud API supports iOS from Version 4.0 and MacOS X from Leopard (10.6). It uses SoundClouds OAuth2 API and henceforth includes the NXOAuth2Client project.

Afraid of doing the journey alone? Don’t be, there’s a lot of places where you can find help:

Please keep in mind that all of this is under heavy development, and things might change from time to time. Please update your frameworks often, and keep this space in mind.

We document the changes to the different versions. If you’ve used a previous version, please read it.

This guide assumes a few things:

  • You are using Xcode 4
  • You are using Git.

Demo

Latest podspec

{
    "name": "CocoaSoundCloudAPI",
    "version": "1.0.2",
    "summary": "A simple way to interact with the SoundCloud  CocoaSoundCloudAPI.",
    "homepage": "https://github.com/soundcloud/CocoaSoundCloudAPI",
    "authors": {
        "Ullrich Schu00e4fer": "[email protected]",
        "Robert Bu00f6hnke": "[email protected]",
        "Tobias Kru00e4ntzer": "[email protected]",
        "Rob Siwek": "[email protected]"
    },
    "platforms": {
        "ios": null
    },
    "source": {
        "git": "https://github.com/soundcloud/CocoaSoundCloudAPI.git",
        "tag": "v1.0.2"
    },
    "source_files": [
        "Sources",
        "Sources/**/*.{h,m}"
    ],
    "frameworks": "Security",
    "dependencies": {
        "NXOAuth2Client": [
            "1.2.2"
        ]
    },
    "license": "Apache License, Version 2.0",
    "requires_arc": false
}

Pin It on Pinterest

Share This