Latest 0.2.0
Homepage https://github.com/ashen-zhao/ZASUpdateAlert
License MIT
Platforms ios 8.0
Authors

platform Swift license

描述:自定义检查版本更新提示弹出框


效果示例图

Showcase


要求

iOS 8.0+
Xcode 7.2+
Swift 4.0+

安装

CocoaPods安装

pod 'ZASUpdateAlert', '~> 0.1.0'
pod 'ZASUpdateAlert', '~> 0.2.0' #(swift4.2)

手动安装

只需将ZASUpdateAlert文件夹拖到项目中。

使用

如果是使用的是CocoaPods,第一步需要先导入ZASUpdateAlert

import ZASUpdateAlert

使用示例

ZASUpdateAlert.show(version: "V1.6", content: "1.全新UI界面n2.更好的性能体验n3.投诉系统极速反馈n4.多个BUG虫的尸体都不复存在", appId: "xxxxxxxx", isMustUpdate: false)

参考项目

https://github.com/RockChanel/SELUpdateAlert

作者

赵阿申, [email protected]

License

ZASUpdateAlert is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "ZASUpdateAlert",
    "version": "0.2.0",
    "summary": "ZASUpdateAlert u662fu68c0u67e5u66f4u65b0u7684u4e00u4e2au81eau5b9au4e49u5f39u6846u3002",
    "description": "ZASUpdateAlert u662fu68c0u67e5u66f4u65b0u7684u4e00u4e2au81eau5b9au4e49u5f39u6846u3002u4e00u884cu4ee3u7801u5c31u53efu4ee5u96c6u6210u3002",
    "homepage": "https://github.com/ashen-zhao/ZASUpdateAlert",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "ZHAOASHEN": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/ashen-zhao/ZASUpdateAlert.git",
        "tag": "0.2.0"
    },
    "source_files": "ZASUpdateAlert/ZASUpdateAlert/ZASUpdateAlert.swift",
    "resources": "ZASUpdateAlert/ZASUpdateAlert/ZASUpdateAlert.bundle",
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "4"
    }
}

Pin It on Pinterest

Share This