Latest 1.0.0
Homepage https://github.com/CoderXYF/XYFAlertView
License MIT
Platforms ios 8.0, requires ARC
Authors

A simple, easy to use, variety of prompting operation frame.一个简单易用多样的提示操作弹框。

Installation

CocoaPods

  1. Add pod 'XYFAlertView' to your Podfile.
  2. Run pod install or pod update.
  3. Import <XYFAlertView.h>.

Manually

  1. Download XYFAlertView and find XYFAlertView/XYFAlertView finder.
  2. Add the source files to your Xcode project.
  3. Import XYFAlertView.h.

Requirements

This library requires iOS 8.0+.

License

XYFAlertView is provided under the MIT license. See LICENSE file for details.

安装

CocoaPods

  1. 在 Podfile 中添加 pod 'XYFAlertView'
  2. 执行 pod installpod update
  3. 导入 <XYFAlertView.h>。

手动安装

  1. 下载 XYFAlertView 并找到 XYFAlertView/XYFAlertView 文件夹。
  2. 将 XYFAlertView 内的源文件添加(拖放)到你的工程。
  3. 导入 XYFAlertView.h

系统要求

该工具最低支持 iOS 8.0

许可证

XYFAlertView 使用 MIT 许可证,详情见 LICENSE 文件。

Preview:

Sample style 1:

img

Sample style 2:

img

Sample style 3:

img

Sample style 4:

img

Sample style 5:

img

Sample style 6:

img

Latest podspec

{
    "name": "XYFAlertView",
    "version": "1.0.0",
    "platforms": {
        "ios": "8.0"
    },
    "summary": "A simple, easy to use, variety of prompting operation frame",
    "homepage": "https://github.com/CoderXYF/XYFAlertView",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "CoderXYF": "[email protected]"
    },
    "source": {
        "git": "https://github.com/CoderXYF/XYFAlertView.git",
        "tag": "1.0.0"
    },
    "source_files": "XYFAlertView/XYFAlertView/*.{h,m}",
    "requires_arc": true
}

Pin It on Pinterest

Share This