Latest 0.3.3
Homepage https://github.com/codewpf/WPFoundation
License MIT
Platforms ios 9.0
Authors




WPFBannerView is support library.

Requirements

  • iOS 9.0+
  • Swift 3.0+

Installation

There are two way to use WPFBannerView in your project, or directly drag the WPFBannerView file into your project:

  • using CocoaPods
  • using Carthage

Installation with CocoaPods

CocoaPods is a dependency manager for Objective-C, which automates and simplifies the process of using 3rd-party libraries in your projects. See the Get Started section for more details.

Podfile

platform :ios, '9.0'
use_frameworks!

target 'target’ do
pod 'WPFoundation'
end

Installation with Carthage (iOS 8+)

Carthage is a lightweight dependency manager for Swift and Objective-C. It leverages CocoaTouch modules and is less invasive than CocoaPods.

To install with carthage, follow the instruction on Carthage

Cartfile

github "codewpf/WPFoundation"

Import headers in your source files

In the source files where you need to use the library, import the header file:

import WPFoundation

Contact

Follow and contact me on Twitter or [Sina Weibo](http://weibo.com/codewpf ). If you find an issue, just open a ticket. Pull requests are warmly welcome as well.

License

WPFBannerView is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "WPFoundation",
    "version": "0.3.3",
    "summary": "WPFoundation is a private foundation framework for Swift develop",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "homepage": "https://github.com/codewpf/WPFoundation",
    "authors": {
        "Alex": "[email protected]"
    },
    "platforms": {
        "ios": "9.0"
    },
    "source": {
        "git": "https://github.com/codewpf/WPFoundation.git",
        "tag": "0.3.3"
    },
    "source_files": "Sources/WPFoundation.swift",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This