Latest 4.1.2-beta.2
Homepage https://github.com/wordpress-mobile/WordPressKit-iOS
License GPLv2
Platforms ios 10.0, requires ARC
Dependencies Alamofire, CocoaLumberjack, WordPressShared, NSObject-SafeExpectations, wpxmlrpc, UIDeviceIdentifier
Authors

WordPressKit for iOS

CircleCI

About

WordPressKit offers a clean and simple WordPress.com and WordPress.org API.

Requirements

  • iOS 9 and above
  • Xcode 9.3 and above

Integrating the Library with CocoaPods

WordPressKit-iOS is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "WordPressKit"

License

WordPressKit-iOS is available under the GPLv2 license. See the LICENSE file for more info.

Latest podspec

{
    "name": "WordPressKit",
    "version": "4.1.2-beta.2",
    "summary": "WordPressKit offers a clean and simple WordPress.com and WordPress.org API.",
    "description": "This framework encapsulates all of the networking calls and entity parsers required to interactnwith WordPress.com and WordPress.org endpoints.",
    "homepage": "https://github.com/wordpress-mobile/WordPressKit-iOS",
    "license": "GPLv2",
    "authors": {
        "WordPress": "[email protected]"
    },
    "platforms": {
        "ios": "10.0"
    },
    "swift_version": "4.2",
    "source": {
        "git": "https://github.com/wordpress-mobile/WordPressKit-iOS.git",
        "tag": "4.1.2-beta.2"
    },
    "source_files": "WordPressKit/**/*.{h,m,swift}",
    "private_header_files": "WordPressKit/Private/*.h",
    "requires_arc": true,
    "header_dir": "WordPressKit",
    "dependencies": {
        "Alamofire": [
            "~> 4.7.3"
        ],
        "CocoaLumberjack": [
            "~> 3.4"
        ],
        "WordPressShared": [
            "~> 1.8.0-beta"
        ],
        "NSObject-SafeExpectations": [
            "0.0.3"
        ],
        "wpxmlrpc": [
            "0.8.4"
        ],
        "UIDeviceIdentifier": [
            "~> 1.1.4"
        ]
    }
}

Pin It on Pinterest

Share This