Latest 0.3.0
Homepage https://github.com/kevinzhow/Waver
License MIT
Platforms ios 7.0, requires ARC
Frameworks CoreGraphics, UIKit, Foundation, QuartzCore
Authors

Build Status

A Siri like wave effect

Waver

Requirements

Waver works on iOS 7.0 and later version and is compatible with ARC projects. It depends on the following Apple frameworks, which should already be included with most Xcode templates:

  • Foundation.framework
  • UIKit.framework
  • CoreGraphics.framework
  • QuartzCore.framework

You will need LLVM 3.0 or later in order to build Waver.

Usage

Cocoapods

CocoaPods is the recommended way to add Waver to your project.

  1. Add a pod entry for Waver to your Podfile pod 'Waver', '~> 0.2.0'
  2. Install the pod(s) by running pod install.
  3. Include Waver wherever you need it with #import "Waver.h".

Or Copy the Waver folder to your project

Example

Waver * waver = [[Waver alloc] initWithFrame:CGRectMake(0, CGRectGetHeight(self.view.bounds)/2.0 - 50.0, CGRectGetWidth(self.view.bounds), 100.0)];

__weak Waver * weakWaver = waver;
waver.waverLevelCallback = ^() {

    [self.recorder updateMeters];

    CGFloat normalizedValue = pow (10, [self.recorder averagePowerForChannel:0] / 50);

    weakWaver.level = normalizedValue;

};
[self.view addSubview:waver];

License

This code is distributed under the terms and conditions of the MIT license.

SpecialThanks

https://github.com/stefanceriu/SCSiriWaveformView

Latest podspec

{
    "name": "Waver",
    "version": "0.3.0",
    "summary": "A Siri Like Wave Effect",
    "description": "                  #Wavernn                  A Siri like wave effectnn                  [![](https://dl.dropboxusercontent.com/u/1599662/waver/waver.png)](https://dl.dropboxusercontent.com/u/1599662/waver/wave.mov)nn                  ## Requirementsnn                  Waver works on iOS 7.0 and later version and is compatible with ARC projects. It depends on the following Apple frameworks, which should already be included with most Xcode templates:nn                  * Foundation.frameworkn                  * UIKit.frameworkn                  * CoreGraphics.frameworkn                  * QuartzCore.frameworknn                  You will need LLVM 3.0 or later in order to build Waver.nn",
    "homepage": "https://github.com/kevinzhow/Waver",
    "screenshots": "https://dl.dropboxusercontent.com/u/1599662/waver/waver.png",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "kevinzhow": "[email protected]"
    },
    "platforms": {
        "ios": "7.0"
    },
    "source": {
        "git": "https://github.com/kevinzhow/Waver.git",
        "tag": "0.3.0"
    },
    "source_files": "Waver/Source/**/*.{h,m}",
    "public_header_files": "Waver/Source/**/*.h",
    "frameworks": [
        "CoreGraphics",
        "UIKit",
        "Foundation",
        "QuartzCore"
    ],
    "requires_arc": true
}

Pin It on Pinterest

Share This