Latest 0.0.1
Homepage https://github.com/qigeligedongdongqiang/WaterFlowCollectionViewLayout
License MIT
Platforms ios 5.0, requires ARC
Authors

WaterFlowCollectionViewLayout is a simple custom layout for collectionView,you can use it to implement waterflow layout easily only needing to realise delegate methods.

How To Start

Installation with CocoaPods

CocoaPods is a dependency manager for Objective-C, which automates and simplifies the process of using 3rd-party libraries like WaterFlowCollectionViewLayout in your projects.

To integrate WaterFlowCollectionViewLayout into your Xcode project using CocoaPods, specify it in your Podfile:

platform :ios, '5.0'

target 'TargetName' do
pod 'WaterFlowCollectionViewLayout', '~> 0.0.2'
end

Usage

@required
- (CGFloat)waterFlowCollectionViewLayout:(WaterFlowCollectionViewLayout *)layout heightForItemAtIndexPath:(NSInteger)index ItemWith:(CGFloat)width;

@optional
- (NSInteger)columnCountOfWaterFlowCollectionViewLayout:(WaterFlowCollectionViewLayout *)layout;
- (CGFloat)columnMarginOfWaterFlowCollectionViewLayout:(WaterFlowCollectionViewLayout *)layout;
- (CGFloat)rowMarginOfWaterFlowCollectionViewLayout:(WaterFlowCollectionViewLayout *)layout;
- (UIEdgeInsets)edgeInsetsOfWaterFlowCollectionViewLayout:(WaterFlowCollectionViewLayout *)layout;

Review

review

License

WaterFlowCollectionViewLayout is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "WaterFlowCollectonViewLayout",
    "version": "0.0.1",
    "summary": "A normal waterflow layout for collectionView.",
    "description": "A normal waterflow layout for collectionView.",
    "license": "MIT",
    "authors": {
        "Ngmm_Jadon": "[email protected]"
    },
    "homepage": "https://github.com/qigeligedongdongqiang/WaterFlowCollectionViewLayout",
    "source": {
        "git": "https://github.com/qigeligedongdongqiang/WaterFlowCollectionViewLayout.git",
        "tag": "0.0.1"
    },
    "source_files": [
        "WaterFlowCollectonViewLayout",
        "*.{h,m}"
    ],
    "requires_arc": true,
    "platforms": {
        "ios": "5.0"
    },
    "ios": {
        "frameworks": [
            "Foundation",
            "UIKit"
        ]
    }
}

Pin It on Pinterest

Share This