Latest 1.0.83
Homepage https://github.com/voxbone-workshop/ios-sdk
License MIT
Platforms ios 9.0, requires ARC
Dependencies VoxImplantSDK, Alamofire, SwiftyJSON, Flurry-iOS-SDK/FlurrySDK
Frameworks Foundation
Authors

Installation Steps:

To integrate VoxboneSDK into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '9.0'
use_frameworks!

target '<Your Target Name>' do
    pod 'VoxboneSDK'
end

Then, run the following command:

pod install

Getting Started:

Import

import VoxboneSDK

Log Level

Voxbone.setLogLevel(.VOXBONE_INFO_LOG_LEVEL)

Shared instance & delegate

var voxbone: Voxbone = Voxbone.shared
voxbone.setVoxboneDelegate(delegate: self)

Connect action

voxbone.connect(false)

Login action

voxbone.loginToVoxbone(withUsername: "your username", andPassword: "your password", andUser: "your user", andAppName: "your app name", andSecret: "your secret")

Start Call action

if let callId = voxbone.createVoxboneCall("phone number") {
        voxbone.startCall(callId, withHeaders: nil)
}

End Call action

if callId != nil {
        voxbone.disconnectCall(callId!, withHeaders: nil)
}

Latest podspec

{
    "name": "VoxboneSDK",
    "version": "1.0.83",
    "summary": "VoxboneSDK framework!",
    "homepage": "https://github.com/voxbone-workshop/ios-sdk",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Jeru00f3nimo Valli": "[email protected]"
    },
    "platforms": {
        "ios": "9.0"
    },
    "requires_arc": true,
    "source": {
        "git": "https://github.com/voxbone-workshop/ios-sdk.git",
        "tag": "1.0.83"
    },
    "source_files": "VoxboneSDK/**/*.{h,swift}",
    "frameworks": "Foundation",
    "dependencies": {
        "VoxImplantSDK": [],
        "Alamofire": [],
        "SwiftyJSON": [],
        "Flurry-iOS-SDK/FlurrySDK": []
    },
    "pushed_with_swift_version": "3.1"
}

Pin It on Pinterest

Share This