Latest 0.1.0
Homepage https://github.com/netmaid/VNLunarCalendar
License MIT
Platforms ios 6.0, requires ARC

CI Status
Version
License
Platform

Usage

Requirements

  • Objective-C
  • Xcode 7.0 or later
  • iOS 6.0 or later
  • Mac OS 10.9 or later

Installation

CocoaPods

  • Insert pod "VNLunarCalendar" to your Podfile.
  • Run pod install.

Simple Description

  • VNLunarCalendar is asian lunisolar calendar library especially targeted on Korean calendar.
  • Main codes from transdate.py has ported to C language.
  • Some of codes has ported to C language from datetime.py.

License

VNLunarCalendar is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "VNLunarCalendar",
    "version": "0.1.0",
    "summary": "The Objective-C module for asian lunisolar calendar (Korean calendar)",
    "description": "The class of VNLunarCalendar class has two functions for calculatingn  lundar date of solar date and solar date of lunar date.nMoreover, the NSDate category class which calculate from lunar date ton  solar date and vice versa has included in this module.nThe solar date is valid from 1881-01-30 (lunar 1881-01-01) ton  2051-02-10 (lunar 2050-12-29), so be careful if you need old date.",
    "homepage": "https://github.com/netmaid/VNLunarCalendar",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": "Chungmin Ahn",
    "source": {
        "git": "https://github.com/netmaid/VNLunarCalendar.git",
        "tag": "v0.1.0"
    },
    "platforms": {
        "ios": "6.0"
    },
    "requires_arc": true,
    "source_files": "VNLunarCalendar/**/*.{h,m,c}",
    "public_header_files": "VNLunarCalendar/**/*.h"
}

Pin It on Pinterest

Share This