Latest 0.5.9
Homepage https://github.com/ripventura/VCUIKit
License MIT
Platforms ios 10.0
Dependencies SwiftMessages, SnapKit, FCAlertView, SVProgressHUD, VCSwiftToolkit
Authors

This is a collection of classes and extensions written in Swift 4 to help you optimize your time when developing iOS applications.
All the code was done by me, so please if you think you can contribute, lets share some thoughts!

When I get some time I will update the Wiki page with detailed description of each class / method.

Version
License
Platform

Example

To run the example project, simply clone the repo and open Example/VCUIKit.xcworkspace.

Requirements

  • iOS >= 10.0

Installation

VCUIKit is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "VCUIKit"
  • Add the following lines on your project’s Info.plist file

NSPhotoLibraryUsageDescription: Accessing photo library

UIViewControllerBasedStatusBarAppearance: NO

NSCameraUsageDescription: Accessing camera

Author

ripventura, [email protected]

License

VCUIKit is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "VCUIKit",
    "version": "0.5.9",
    "summary": "A collection of classes and extensions written in Swift 4 to help you optimize your time when developing iOS applications.",
    "description": "This is a collection of classes and extensions written in Swift 4 to help you optimize your time when developing iOS applications. All the code was done by me, so please if you think you can contribute, lets share some thoughts!nnWhen I get some time I will update the Wiki page with detailed description of each class / method.",
    "homepage": "https://github.com/ripventura/VCUIKit",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "ripventura": "[email protected]"
    },
    "source": {
        "git": "https://github.com/ripventura/VCUIKit.git",
        "tag": "0.5.9"
    },
    "platforms": {
        "ios": "10.0"
    },
    "source_files": "VCUIKit/Classes/**/*",
    "dependencies": {
        "SwiftMessages": [
            "~> 4.0"
        ],
        "SnapKit": [
            "~> 4.0"
        ],
        "FCAlertView": [
            "~> 1.4"
        ],
        "SVProgressHUD": [
            "~> 2.2"
        ],
        "VCSwiftToolkit": [
            " ~> 0.1"
        ]
    }
}

Pin It on Pinterest

Share This