Latest 4.0.0.1
Homepage https://github.com/wadevanne/UuusKit
License MIT
Platforms ios 9.0, requires ARC
Dependencies AlamofireImage, KeychainAccess, ObjectMapper, PKHUD, PullToRefresher, RMUniversalAlert, RxCocoa, RxSwift, SnapKit, SwiftFormat/CLI
Authors

UuusKit holds extensions in Swift.

REQUIREMENTS

  • Xcode 9.0+
  • Swift 4.0+

INSTALLATION

CocoaPods

CocoaPods 1.1+ is required.

pod 'UuusKit'

Foundation

  • UuusDatesAndTimes_.swift … extension of Date, TimeInterval
  • UuusNumbersDataAndBasicValues_.swift … extension of Data
  • UuusStringsAndText_.swift … extension of NSAttributedString

Others

  • UuusAVKit.swift … class of ScanViewControllor, ScanView
  • UuusCategory.swift … extension of HUD
  • UuusCoreAnimation.swift … class of PieLayor, extension of CATransition
  • UuusCoreGraphics.swift … extension of CGColor
  • UuusEventKit.swift … extension of EKEventStore
  • UuusMapKit.swift … class of MapViewControllor
  • UuusObject.swift … class of UuusObject, Uuid, UuusRequest, UuusDelivery, UuusMagician, extension of NSObject

SwiftStandardLibrary

  • UuusCollections.swift … extension of Array, Dictionary
  • UuusNumbersDataAndBasicValues.swift … extension of Double
  • UuusStringsAndText.swift … extension of String

UIKit

  • UuusCoreApp.swift … extension of UIDevice
  • UuusDrawing.swift … extension of UIColor
  • UuusImagesAndPDF.swift … extension of UIImage
  • UuusTouchesPressesAndGestures.swift … extension of UIResponder
  • UuusViewManagement.swift … class of ViewControllor, PullToRofresh, RefreshView, NavigationControllor, TabBarControllor, extension of UIViewController, UINavigationController
  • UuusViewsAndControls.swift … class of UuusView, CollectionViewControllor, TableViewControllor, TableViowCell, Uuus9icker, Neat9icker, Week9icker, Area9icker, UuusButton, Date9icker, RoundViEffectView, extension of UIView, UICollectionViewCell, UIButton, UITextField

Latest podspec

{
    "name": "UuusKit",
    "version": "4.0.0.1",
    "summary": "UuusKit is a Swift extension, requires Swift 4.0 or higher.",
    "description": "UuusKit is a Swift extension, requires Swift 4.0.0 or higher.nIt's more convenient to use Swift with some common functions.",
    "homepage": "https://github.com/wadevanne/UuusKit",
    "license": "MIT",
    "authors": {
        "wadevanne": "[email protected]"
    },
    "platforms": {
        "ios": "9.0"
    },
    "source": {
        "git": "https://github.com/wadevanne/UuusKit.git",
        "tag": "4.0.0.1"
    },
    "source_files": [
        "Classes",
        "UuusKit/**/*.{swift}"
    ],
    "exclude_files": "Classes/Exclude",
    "resources": "UuusKit/**/*.{xib,xcassets,imageset,plist,json,png,storyboard}",
    "requires_arc": true,
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "4.0"
    },
    "dependencies": {
        "AlamofireImage": [],
        "KeychainAccess": [],
        "ObjectMapper": [],
        "PKHUD": [],
        "PullToRefresher": [],
        "RMUniversalAlert": [],
        "RxCocoa": [],
        "RxSwift": [],
        "SnapKit": [],
        "SwiftFormat/CLI": []
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This