Latest 0.5.1
Homepage https://github.com/mruegenberg/uikit-utils
License MIT
Platforms ios 5.1, requires ARC
Dependencies ios-versioncheck
Frameworks UIKit
Authors

Utilities for UIKit

This is a collection of useful classes and extensions for common classes in UIKit. It is extracted from the objc-utils project.

What is in here

  • Various categories to make the standard UIKit classes more useful
  • A few helper classes with the same purpose

Compatibility

  • All code requires an ARC (Automatic Reference Counting) capable compiler.
  • Everything should be compatible with the iOS SDK 5 or above

How to use

Just copy the files you need (and their dependencies) to your project.

You can also use uikit-utils with CocoaPods.

0.5. vs 0.4.

  • PopoverManager was renamed to DLPopoverManager
  • UIDeviceHardware removed. Use UIDevice-Hardware instead.
  • -[UIColor prussianBlueColor] removed
  • UIColor+HelperAdditions.{h,m} ~> UIColor+DLHelperAdditions.{h,m}
  • UIImage+Additions ~> UIImage+DLAdditions

License

MIT.
(Before version 0.5.0, the code used a custom permissive license.)

Contact

Travis CI build status

Bug reports and pull requests are welcome! Contact me via e-mail or just by opening an issue on GitHub.

Latest podspec

{
    "name": "uikit-utils",
    "version": "0.5.1",
    "summary": "Utilities for UIKit",
    "description": "                    This is a collection of useful classes and extensions for common classes in UIKit.n                  n                    * Various categories to make the standard UIKit classes more useful.n                    * A few helper classes with the same purpose.n",
    "homepage": "https://github.com/mruegenberg/uikit-utils",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Marcel Ruegenberg": "[email protected]"
    },
    "platforms": {
        "ios": "5.1"
    },
    "requires_arc": true,
    "source": {
        "git": "https://github.com/mruegenberg/uikit-utils.git",
        "tag": "0.5.1"
    },
    "source_files": "Classes/**/*.{h,m}",
    "resources": "Resources/*.png",
    "frameworks": "UIKit",
    "dependencies": {
        "ios-versioncheck": [
            "~> 1.0.1"
        ]
    }
}

Pin It on Pinterest

Share This