Latest 1.2.1
Homepage https://github.com/Touch-Tech-Payments/3DS-iOS
License Apache 2.0
Platforms ios 9.0
Dependencies Starscream
Authors

CocoaPods
Carthage compatible

3DS-iOS

Installation

Touchtech 3DS for iOS supports iOS 9, iOS 10 and iOS 11.

CocoaPods

Add the Touchtech 3DS-iOS pod into your Podfile and run pod install.

    target :YourTargetName do
      pod 'TTPaymentsOTP'
    end

Carthage

  1. Add github "Touch-Tech-Payments/3DS-iOS" to your Cartfile.
  2. Run carthage update.
  3. Go to your Xcode project’s "General" settings. Drag TTPaymentsOTP.framework from Carthage/Build/iOS to the "Embedded Binaries" section. Make sure “Copy items if needed” is selected and click Finish.

Latest podspec

{
    "name": "TTPaymentsOTP",
    "version": "1.2.1",
    "summary": "The Touchtech Payments iOS SDK, for integrating TouchTech Payments authentication into your iOS application.",
    "description": "The TouchTech Payments iOS SDK, for integrating TouchTech Payments authentication into your iOS application. This SDK supports iOS 9 and above.",
    "homepage": "https://github.com/Touch-Tech-Payments/3DS-iOS",
    "license": {
        "type": "Apache 2.0",
        "file": "TTPaymentsOTP/LICENSE"
    },
    "authors": {
        "David Parsons": "[email protected]"
    },
    "source": {
        "http": "https://github.com/Touch-Tech-Payments/3DS-iOS/releases/download/v1.2.1/CocoaPods.tar.gz"
    },
    "platforms": {
        "ios": "9.0"
    },
    "swift_version": "4.2",
    "dependencies": {
        "Starscream": [
            "~> 3.0"
        ]
    },
    "ios": {
        "vendored_frameworks": "TTPaymentsOTP/TTPaymentsOTP.framework"
    }
}

Pin It on Pinterest

Share This