Latest 0.9.0
Homepage https://github.com/royhsu/tiny-kit
License MIT
Platforms ios 10.0
Dependencies TinyCore, TinyValidation
Frameworks UIKit
Authors

CocoaPods Compatible
Carthage compatible
Platform

TinyKit provides practical functionalities that will help us to build apps much more quickly.

Requirements

  • iOS 10.0+
  • Swift 4.0+

Installation

You can install TinyKit using CocoaPods or Carthage.

CocoaPods

use_frameworks!

pod 'TinyKit'

Carthage

github 'royhsu/TinyCore'
github 'royhsu/TinyStorage'
github 'royhsu/TinyKit'

Latest podspec

{
    "name": "TinyKit",
    "version": "0.9.0",
    "license": "MIT",
    "summary": "TinyKit provides practical functionalities that will help us to build apps much more quickly.",
    "homepage": "https://github.com/royhsu/tiny-kit",
    "authors": {
        "Roy Hsu": "[email protected]"
    },
    "source": {
        "git": "https://github.com/royhsu/tiny-kit.git",
        "tag": "0.9.0"
    },
    "frameworks": "UIKit",
    "source_files": [
        "Sources/Core/Sources/*.swift",
        "Sources/Core/Sources/**/*.swift",
        "Sources/Core/Sources/**/**/*.swift",
        "Sources/Core/Sources/**/**/**/*.swift"
    ],
    "ios": {
        "source_files": [
            "Sources/iOS/Sources/*.swift",
            "Sources/iOS/Sources/**/*.swift",
            "Sources/iOS/Sources/**/**/*.swift",
            "Sources/iOS/Sources/**/**/**/*.swift"
        ]
    },
    "platforms": {
        "ios": "10.0"
    },
    "swift_version": "4.2",
    "dependencies": {
        "TinyCore": [
            "0.7.0"
        ],
        "TinyValidation": [
            "0.2.0"
        ]
    }
}

Pin It on Pinterest

Share This