Latest 1.1
Homepage https://github.com/karthikAdaptavant/TestPushNotification
License MIT
Platforms ios 9.0
Dependencies Alamofire, SwiftyJSON
Authors

🚀 TestPushNotification 🚀

CI Status
Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

TestPushNotification is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'TestPushNotification'

🤞 Usage 🤞

        let authKey = "{your auth key goes here}"

        let fcmKey = ["c7igErTWSB0:APA91bFoYmSqQa-v-xZkpWRYvXWEfvE79fme4jVAQTTyhHjdFi6_Q9tP3uskevnnB2_5_WTeLkrCZyok2F_JFR3b2NgAoyEVCgwVWAgFcPZoRTZR5neaibqaTTgad4AyeOnew5sGEyHf"]

        let data = NotificationData(title: "Karthik", body: "Hi, there this is test")

        let pushData = PushNotificationData(authKey: authKey, fcmToken: fcmKey, notificationData: data)

        let testPush = TestPushManager(pushData: pushData)

        testPush.fire()

Author

karthikAdaptavant, [email protected]

License

TestPushNotification is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "TestPushNotification",
    "version": "1.1",
    "swift_version": "4.0",
    "summary": "A candy for firing notification with custom payloads",
    "description": "Testing Notification is always hard when it comes to iOS. Here is a small chunk which uses firebase api, where you can pass your custom payload to fire a notification.",
    "homepage": "https://github.com/karthikAdaptavant/TestPushNotification",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "karthikAdaptavant": "[email protected]"
    },
    "source": {
        "git": "https://github.com/karthikAdaptavant/TestPushNotification.git",
        "tag": "1.1"
    },
    "social_media_url": "https://twitter.com/i_am_kaarthik",
    "platforms": {
        "ios": "9.0"
    },
    "source_files": "TestPushNotification/Classes/**/*",
    "dependencies": {
        "Alamofire": [
            "~> 4.7"
        ],
        "SwiftyJSON": [
            "4.0"
        ]
    }
}

Pin It on Pinterest

Share This