Latest 0.2.3
Homepage https://github.com/amrap-labs/TeamupKit
License MIT
Platforms ios 9.0, requires ARC
Dependencies KeychainSwift, Alamofire
Authors

TeamupKit
TeamupKit

Build Status
Swift 4.0
[CocoaPods]()
Carthage compatible
codecov
GitHub release

A Swift framework for integrating with Teamup: all-in-one management software for top fitness businesses.

Requirements

TeamupKit requires Swift 4.0 and works with iOS 9 and above.

Installation

CocoaPods

Add TeamupKit to your Podfile:

pod 'TeamupKit'

Carthage

Add TeamupKit to your Cartfile:

github "amrap-labs/TeamupKit"

Dependencies

TeamupKit requires the following dependencies to function:

Getting Started

Basics

Initialize a Teamup session:

import TeamupKit

let teamup = Teamup(apiToken: "API_TOKEN",
                    businessId: BUSINESS_ID)

You are required to have an API token and business identifier to initialize a Teamup session. In order to gain an API token you will need to request one from Teamup (Submit a request).

Once you have successfully configured a session, you can use any of the API’s available in TeamupKit.

Documentation is still very much a work in progress…

Latest podspec

{
    "name": "TeamupKit",
    "platforms": {
        "ios": "9.0"
    },
    "requires_arc": true,
    "version": "0.2.3",
    "summary": "Swift framework for Teamup services.",
    "description": "Swift framework for communicating with Teamup, a service to super charge your fitness business.",
    "homepage": "https://github.com/amrap-labs/TeamupKit",
    "license": "MIT",
    "authors": {
        "Merrick Sapsford": "[email protected]"
    },
    "social_media_url": "http://twitter.com/MerrickSapsford",
    "source": {
        "git": "https://github.com/amrap-labs/TeamupKit.git",
        "tag": "0.2.3"
    },
    "source_files": "Sources/TeamupKit/**/*.{h,m,swift}",
    "resource_bundles": {
        "TeamupKit": [
            "Sources/TeamupKit/Resources/**/*"
        ]
    },
    "dependencies": {
        "KeychainSwift": [
            "~> 8.0"
        ],
        "Alamofire": [
            "~> 4.5.0"
        ]
    }
}

Pin It on Pinterest

Share This