Latest 0.1
Homepage https://github.com/cyrilwei/TCCalendar
License MIT
Platforms ios 8.0, requires ARC
Frameworks UIKit

Requirements

  • iOS 8.0+
  • Xcode 7

Integration

CocoaPods (iOS 8+)

You can use CocoaPods to install TCCalendar by adding it to your Podfile:

platform :ios, '8.0'
use_frameworks!

target 'YourApp' do
  pod 'TCCalendar'
end

Swift Package Manager

You can use The Swift Package Manager to install TCCalendar by adding the proper description to your Package.swift file:

import PackageDescription

let package = Package(
    name: "YOUR_PROJECT_NAME",
    dependencies: [
        .Package(url: "https://github.com/cyrilwei/TCCalendar.git", versions: "0.1" ..< Version.max)
    ]
)

Latest podspec

{
    "name": "TCCalendar",
    "version": "0.1",
    "summary": "An iOS calendar view, built in Swift",
    "description": "This is a calendar view that you can config the selection behaviour and decorate the cell style with some very simple closures.nYou can also subclass the cells or use UIAppearance to control them all.",
    "homepage": "https://github.com/cyrilwei/TCCalendar",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": "Cyril Wei",
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/cyrilwei/TCCalendar.git",
        "tag": "v0.1"
    },
    "source_files": "TCCalendar/TCCalendar/*.swift",
    "frameworks": "UIKit",
    "requires_arc": true
}

Pin It on Pinterest

Share This