Latest 2.1
Homepage https://github.com/taktem/TAKAlertUtil
License MIT
Platforms ios 8.0, requires ARC
Dependencies ReactiveCocoa
Authors

UIAlertViewとUIAlertControllerを、OS判別した上で分岐する

Installation with CocoaPods

Podfile

pod 'TAKAlertUtil'

Requirements

This is in need of ReactiveCocoa

Get Started

#import "TAKAlertUtil.h"
[[TAKAlertUtil showWithTitle:@"Title"
                     message:@"Alert message"
                buttonTitles:@[@"Cancel",@"OK"]] subscribeNext:^(id x) {
        if ([x intValue] == 0) {
            NSLog(@"Cancel button tapped.");
        } else {
            NSLog(@"OK button tapped.");
        }
    }];

License

TAKAlertUtil is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "TAKAlertUtil",
    "platforms": {
        "ios": "8.0"
    },
    "version": "2.1",
    "summary": "UIAlertController Support",
    "license": {
        "type": "MIT",
        "file": "LICENSE.txt"
    },
    "homepage": "https://github.com/taktem/TAKAlertUtil",
    "authors": {
        "SOMTD": "nishimura[at]taktem.com"
    },
    "source": {
        "git": "https://github.com/taktem/TAKAlertUtil.git",
        "tag": "2.1"
    },
    "requires_arc": true,
    "source_files": "TAKAlertUtil/**/*.{h,m}",
    "public_header_files": "TAKAlertUtil/**/*.{h}",
    "dependencies": {
        "ReactiveCocoa": [
            "~> 4.1.0"
        ]
    }
}

Pin It on Pinterest

Share This