Latest 0.4.1
Homepage https://github.com/eastsss/SwiftyUtilities
License MIT
Platforms ios 8.0
Authors

CI Status
Version
Swift v3.2
License
Platform

Installation

SwiftyUtilities is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "SwiftyUtilities"

Versions

Swift Version Pod Version
3.0 0.3.0+
3.2 0.4.0+

Author

eastsss, [email protected]

License

SwiftyUtilities is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "SwiftyUtilities",
    "version": "0.4.1",
    "summary": "A collection of reusable boilerplate code.",
    "homepage": "https://github.com/eastsss/SwiftyUtilities",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "eastsss": "[email protected]"
    },
    "source": {
        "git": "https://github.com/eastsss/SwiftyUtilities.git",
        "tag": "0.4.1"
    },
    "platforms": {
        "ios": "8.0"
    },
    "default_subspecs": "Foundation",
    "pushed_with_swift_version": "3.2",
    "subspecs": [
        {
            "name": "Foundation",
            "source_files": "SwiftyUtilities/Foundation/**/*",
            "frameworks": "Foundation"
        },
        {
            "name": "UIKit",
            "source_files": "SwiftyUtilities/UIKit/**/*",
            "frameworks": "UIKit"
        },
        {
            "name": "Networking",
            "source_files": "SwiftyUtilities/Networking/**/*",
            "dependencies": {
                "SwiftyUtilities/Foundation": [],
                "Moya/ReactiveSwift": [
                    "~> 9.0.0"
                ],
                "Argo": [
                    "~> 4.1.2"
                ],
                "Curry": [
                    "~> 3.0.0"
                ],
                "Ogra": [
                    "~> 4.1.1"
                ]
            }
        },
        {
            "name": "Reactive",
            "source_files": "SwiftyUtilities/Reactive/**/*",
            "dependencies": {
                "SwiftyUtilities/Foundation": [],
                "ReactiveCocoa": [
                    "~> 6.0.2"
                ]
            }
        },
        {
            "name": "ReactivePortionLoader",
            "source_files": "SwiftyUtilities/ReactivePortionLoader/**/*",
            "dependencies": {
                "SwiftyUtilities/Foundation": [],
                "SwiftyUtilities/Networking": []
            }
        }
    ]
}

Pin It on Pinterest

Share This