Latest 0.3.4
Homepage https://github.com/kinetic-fit/sensors-swift-trainers
License MIT
Platforms ios 8.2, osx 10.11
Dependencies SwiftySensors, Signals
Authors

Bike Trainers Plugin for Swifty Sensors

iOS
macOS
Swift 3.0
License
CocoaPods

This Swifty Sensor plugin adds Services and Characteristics for various Bike Trainers.

Installation

CocoaPods

use_frameworks!
pod 'SwiftySensors'
pod 'SwiftySensorsTrainers'

Manual

Copy all of the swift files in the Sources directory into you project. Also copy the Headers and Libraries directories. Include the appropriate libs for your project. You may need to add some includes to the header files in your Bridging Header (and create one if you don’t have one).

Swift Package Manager

This library is not compatible with Swift Package Manager yet. It relies upon some Objective C SDK libraries and Objective C libs are not supported in the SPM yet.

Usage

When setting up your SensorManager, simply add the various Trainer Services to the scan list.


import SwiftySensors
import SwiftySensorsTrainers

// Customize what services you want to scan for
SensorManager.instance.setServicesToScanFor([
    CyclingPowerService.self,
    ...
    InRide2Service.self,
    SmartControlService.self,
    CycleOpsService.self
])

## Known bugs
None.

## ToDos

Latest podspec

{
    "name": "SwiftySensorsTrainers",
    "version": "0.3.4",
    "summary": "Trainer Plugins for SwiftySensors",
    "homepage": "https://github.com/kinetic-fit/sensors-swift-trainers",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Kinetic": "[email protected]"
    },
    "platforms": {
        "ios": "8.2",
        "osx": "10.11"
    },
    "source": {
        "git": "https://github.com/kinetic-fit/sensors-swift-trainers.git",
        "tag": "0.3.4"
    },
    "source_files": [
        "Source/**/*.swift",
        "Headers/*.h"
    ],
    "ios": {
        "vendored_libraries": "Libraries/libKineticSDK.a"
    },
    "osx": {
        "vendored_libraries": "Libraries/libKineticSDKCocoa.a"
    },
    "dependencies": {
        "SwiftySensors": [
            "~>0.3"
        ],
        "Signals": [
            "~> 4.0"
        ]
    },
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This