Latest 4.2.1
Homepage https://github.com/tsrnd/swiftutils-ios
License MIT
Platforms ios 8.0, requires ARC
Authors

Build Status
CocoaPods Compatible
Platform
Coverage Status

SwiftUtils

Requirements

  • iOS 8.0+
    Version 4.0.2: – Xcode 9 ~ Swift 4.0+
    Version 4.2: – Xcode 10 ~ Swift 4.2+

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

CocoaPods 1.2.0+ is required to build SwiftUtils 4.0+.

To integrate SwiftUtils into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'SwiftUtils', '4.2'

Then, run the following command:

$ pod install

Latest podspec

{
    "name": "SwiftUtils",
    "version": "4.2.1",
    "license": "MIT",
    "summary": "SwiftUtils",
    "homepage": "https://github.com/tsrnd/swiftutils-ios",
    "authors": {
        "Dao Nguyen": "zendobk"
    },
    "source": {
        "git": "https://github.com/tsrnd/swiftutils-ios.git",
        "tag": "4.2.1"
    },
    "requires_arc": true,
    "platforms": {
        "ios": "8.0"
    },
    "ios": {
        "frameworks": [
            "Foundation",
            "UIKit"
        ]
    },
    "source_files": [
        "Sources/Classes/*.swift",
        "Sources/Extensions/*.swift"
    ]
}

Pin It on Pinterest

Share This