Latest 1.1.6
Homepage https://github.com/ryanchang0827/SwiftPlugin-God
License MIT
Platforms ios 8.0, requires ARC
Dependencies Alamofire, SwiftyJSON, MBProgressHUD
Authors

Requirements

  • iOS 8.0+

Install

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

To integrate SwiftPlugin-God into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'SwiftPlugin-God'

Then, run the following command:

$ pod install

Usage

with Parameters

let params :[String:AnyObject!] = [ "a":"a", "b":"b" ]
callapi("http://www.google.com", .POST, params) { (result) -> () in
  print("(__FUNCTION__) " + result.description)
  print(result)
}

without Parameters

callapi("http://www.google.com", .POST) { (result) -> () in
  print("(__FUNCTION__) " + result.description)
  print(result)
}

Latest podspec

{
    "name": "SwiftPlugin-God",
    "version": "1.1.6",
    "summary": "SwiftPlugin-God",
    "homepage": "https://github.com/ryanchang0827/SwiftPlugin-God",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Chi Chang": "[email protected]"
    },
    "source": {
        "git": "https://github.com/ryanchang0827/SwiftPlugin-God.git",
        "tag": "1.1.6"
    },
    "source_files": "SwiftPlugin-God/*.swift",
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "dependencies": {
        "Alamofire": [
            "3.0.1"
        ],
        "SwiftyJSON": [
            "2.3.0"
        ],
        "MBProgressHUD": [
            "0.9.1"
        ]
    }
}

Pin It on Pinterest

Share This