Latest 1.0.6
Homepage https://github.com/15038777234/SwiftAlertController
License MIT
Platforms ios 8.0, requires ARC
Authors

This is the Swift support UIAlertView and UIAlertController version of third-party libraries(这是支持UIAlertView和UIAlertController 的Swift 版本的第三方库)

支持 Cocoapods(Support Cocoapods)

pod 'SwiftAlertController'

使用(use)

var alertStyle = SwiftAlertControllerStyle.alertView
// 设置为actionSheet
alertStyle = SwiftAlertControllerStyle.actionSheet
let alert:SwiftAlertController = SwiftAlertController(style: alertStyle, title: nil, message: "alert", otherButtons: ["Other"])
 alert.showAlertController(self, complete: nil)

备注:因为Cocoapods 推送里面的API必须在IOS8以上 所以改成了IOS8以上 如果想要支持IOS8之前的请下载relase1.0.0版本

Note: because Cocoapods push the API must be above IOS8 inside So changed to IOS8 above If you want to support before IOS8 relase1.0.0 version, please download

Latest podspec

{
    "name": "SwiftAlertController",
    "version": "1.0.6",
    "summary": "This is the Swift support UIAlertView and UIAlertController version of third-party libraries",
    "description": "This is the Swift support UIAlertView and UIAlertController version of third-party libraries(u8fd9u662fu652fu6301UIAlertViewu548cUIAlertController u7684Swift u7248u672cu7684u7b2cu4e09u65b9u5e93)",
    "homepage": "https://github.com/15038777234/SwiftAlertController",
    "license": "MIT",
    "authors": {
        "15038777234": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/15038777234/SwiftAlertController.git",
        "tag": "1.0.6"
    },
    "source_files": "Classes/*.swift",
    "requires_arc": true
}

Pin It on Pinterest

Share This