Latest 1.0.5
Homepage https://github.com/square1-io/Square1-iOS-CoreData
License MIT
Platforms ios 10.0
Dependencies Square1Tools

Square1 CoreData

CocoapodsPlatform

A collection of helpers to work with CoreData

Prerequisites

  • iOS 10.0+
  • XCode 9+
  • Swift 4+

Installing

Cocoapods

If you’re already using Cocoapods in your project, just skip to step 3

  1. Install Cocoapods
  2. Create a Podfile for your project
  3. Make sure you use
    use_frameworks!
  4. Add this pod to your Podfile
    pod 'Square1CoreData'
  5. Run pod install
  6. Use this import on every file you want to use the pod
    import Square1CoreData

Running the tests

  1. Download the source project
  2. Hit Cmd + U to run the tests.

Dependecies

Already handled by pod (run pod install):

Contributing

Please read CONTRIBUTING for details on our code of conduct, and the process for submitting pull requests to us.

Authors

License

This project is licensed under the MIT License – see the LICENSE file for details

Acknowledgments

To Chris Eidhof, Daniel Eggert and Florian Kugler at objc.io for their value sessions.

Latest podspec

{
    "name": "Square1CoreData",
    "version": "1.0.5",
    "summary": "A collection of tools used in our Swift projects",
    "description": "A handy collection of helpers for dealing with CoreData",
    "homepage": "https://github.com/square1-io/Square1-iOS-CoreData",
    "license": {
        "type": "MIT",
        "file": "LICENSE.md"
    },
    "authors": "Square1",
    "platforms": {
        "ios": "10.0"
    },
    "source": {
        "git": "https://github.com/square1-io/Square1-iOS-CoreData.git",
        "tag": "1.0.5"
    },
    "source_files": [
        "Source",
        "Source/**/*.swift"
    ],
    "dependencies": {
        "Square1Tools": []
    }
}

Pin It on Pinterest

Share This