Latest 1.3.7
Homepage https://github.com/robbroadwell/space-x
License MIT
Platforms ios 10.0, requires ARC
Dependencies Alamofire, SwiftyJSON
Authors

space-x

Swift API wrapper for SpaceX launch data.

Installation:

    pod 'SpaceX'

Usage:

    API.request { (launches) in
        // 'launches' is an array of SpaceX launch objects
    }

Latest podspec

{
    "name": "SpaceX",
    "platforms": {
        "ios": "10.0"
    },
    "swift_version": "4.0",
    "requires_arc": true,
    "version": "1.3.7",
    "summary": "A wrapper for the SpaceX launch API.",
    "description": "A simple API wrapper for the SpaceX launch API. Allows the rapid development of applications relating to SpaceX.",
    "homepage": "https://github.com/robbroadwell/space-x",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Rob Broadwell": "[email protected]"
    },
    "source": {
        "git": "https://github.com/robbroadwell/space-x.git",
        "tag": "1.3.7"
    },
    "source_files": "SpaceX/*.swift",
    "exclude_files": "Classes/Exclude",
    "dependencies": {
        "Alamofire": [
            "~> 4.6.0"
        ],
        "SwiftyJSON": [
            "~> 4.0.0"
        ]
    }
}

Pin It on Pinterest

Share This