Latest 0.3.0
Homepage https://github.com/hryk224/SnapView
License MIT
Platforms ios 8.0, requires ARC
Frameworks UIKit
Authors

Using UISnapBehavior to Add bouncy snap movement animations to your views.


SnapView
SnapView

Requirements

  • iOS 8.0+
  • Swift 2.0+
  • ARC

Feature

  • [x] View
  • [x] Button
  • [x] ImageView

install

Cocoapods

Adding the following to your Podfile and running pod install:

use_frameworks!
pod "SnapView"

import

import SnapView

Usage

SnapView
SnapView

Acknowledgements

  • Inspired by tumblr App

License

This project is made available under the MIT license. See LICENSE file for details.

Latest podspec

{
    "name": "SnapView",
    "version": "0.3.0",
    "summary": "Add bouncy snap movement animations to your views.",
    "homepage": "https://github.com/hryk224/SnapView",
    "screenshots": "https://github.com/hryk224/SnapView/wiki/images/sample1.gif",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "hyyk224": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/hryk224/SnapView.git",
        "tag": "0.3.0"
    },
    "source_files": "Sources/*.{h,swift}",
    "frameworks": "UIKit",
    "requires_arc": true,
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This