Latest 1.0.2
Homepage https://github.com/Bruce-pac/SlideDrawer
License MIT
Platforms ios 8.0
Authors

CI Status
Version
Carthage
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

  • iOS 8.0+
  • Swift 4.0+

Installation

CocoaPods

SlideDrawer is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'SlideDrawer'

Carthage

To integrate SlideDrawer into your Xcode project using Carthage, specify it in your Cartfile:

github "Bruce-pac/SlideDrawer"

Then, run the following command to build the SlideDrawer framework:

$ carthage update --platform ios

At last, you need to set up your Xcode project manually to add the SlideDrawer framework:

  1. On your application targets’ “General” settings tab, in the “Linked Frameworks and Libraries” section, drag and drop each framework you want to use from the Carthage/Build folder on disk.
  2. On your application targets’ “Build Phases” settings tab, click the “+” icon and choose “New Run Script Phase”. Create a Run Script with the following content:
/usr/local/bin/carthage copy-frameworks
  1. Add the paths to the frameworks you want to use under “Input Files”:
$(SRCROOT)/Carthage/Build/iOS/SlideDrawer.framework
  1. Add the paths to the copied frameworks to the “Output Files”:
$(BUILT_PRODUCTS_DIR)/$(FRAMEWORKS_FOLDER_PATH)/SlideDrawer.framework

Usage

let vc = LeftViewController()
//self is the main/center ViewController
self.sd.show(drawer: vc) //default left
// you can set direction right by this
self.sd.show(drawer: vc) { (letConfig) -> SlideDrawerConfiguration in
                var config = letConfig
                config.direction = .right
                return config
            }

See Examples for more usage

Author

Bruce-pac, [email protected]

License

SlideDrawer is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "SlideDrawer",
    "version": "1.0.2",
    "summary": "A lightweight, no intrusionuff0cone line code to use, Slide Drawer written Swift4.",
    "description": "A lightweight, no intrusionuff0cone line code to use, Slide Drawer written Swift4.Do not need to set up leftviewcontroller and rightviewcontroller.",
    "homepage": "https://github.com/Bruce-pac/SlideDrawer",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Bruce-pac": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Bruce-pac/SlideDrawer.git",
        "tag": "1.0.2"
    },
    "platforms": {
        "ios": "8.0"
    },
    "swift_version": "4.2",
    "source_files": "SlideDrawer/Classes/**/*"
}

Pin It on Pinterest

Share This