Latest 0.3.2
Homepage https://github.com/bulusoy/Skiplagged
License MIT
Platforms ios 8.0, requires ARC
Dependencies Gloss
Authors

![CI Status](http://img.shields.io/travis/Bilge Taylan Ulusoy/Skiplagged.svg?style=flat)
Version
License
Platform

Usage

To run the example project, clone the repo, and run pod install from the Example directory first.

Get Airports by hint

let skippy: Skiplagged = Skiplagged()

skippy.getAirportCodesByHint("Lux", result: { (array:[SLAirport]?, error:NSError?) -> Void in
    // Do whatever you want with the array
})

Search for flights

skippy.getFlights(SLAirport(code: "HAM", name: nil), to: SLAirport(code: "LUX", name: nil), departureDate: NSDate().dateByAddingTimeInterval(43200), returnDate: NSDate().dateByAddingTimeInterval(43200 * 8), sort: .Pricing, result: { (airlines, trips, depart, cities, error) -> Void in
    // If you want to get return flights as well...
    skippy.getReturnFlights((trips?.first)!, returnDate: NSDate().dateByAddingTimeInterval(43200 * 8), sort: .Pricing, result: { (airlines, flights, depart, cities, error) -> Void in

    })
})

Requirements

Installation

Skiplagged is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "Skiplagged"

Author

Bilge Taylan Ulusoy, bilge.ulusoy@me.com

License

Skiplagged is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Skiplagged",
    "version": "0.3.2",
    "summary": "API Client for skiplagged.com",
    "description": "If you don't know it, then you won't need it :)",
    "homepage": "https://github.com/bulusoy/Skiplagged",
    "license": "MIT",
    "authors": {
        "Bilge Taylan Ulusoy": "bilge.ulusoy@me.com"
    },
    "source": {
        "git": "https://github.com/bulusoy/Skiplagged.git",
        "branch": "master",
        "tag": "0.3.2"
    },
    "social_media_url": "https://twitter.com/bulusoy",
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "source_files": "Pod/Classes/**/*",
    "dependencies": {
        "Gloss": [
            "~> 0.6.0"
        ]
    }
}

Pin It on Pinterest

Share This