Latest 1.1.0
Homepage https://github.com/ridi/simple-service-status-ios
License MIT
Platforms ios 8.0
Dependencies Alamofire, SwiftyUserDefaults
Authors

SimpleServiceStatus Client for iOS

Screenshot of the demo project

Requirements

  • Xcode 10.2+
  • Swift 4.2
  • iOS8+

Getting Started

You need to install the CocoaPods to add this library as a dependency in your project.

gem install cocoapods

Add the line below to the Podfile of your project.

pod ‘SimpleServiceStatus’

From terminal, navigate to the directory containing the Podfile, then

pod install

For more details, please have a look at the SimpleServiceStatus-Demo Xcode project in this repository, and the podspec file.

Latest podspec

{
    "name": "SimpleServiceStatus",
    "version": "1.1.0",
    "authors": {
        "Ridibooks Viewer Team": "[email protected]"
    },
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "homepage": "https://github.com/ridi/simple-service-status-ios",
    "source": {
        "git": "https://github.com/ridi/simple-service-status-ios.git",
        "tag": "1.1.0"
    },
    "summary": "SimpleServiceStatus SDK for iOS",
    "screenshots": "https://raw.githubusercontent.com/ridi/simple-service-status-ios/master/screenshot-demo.png",
    "platforms": {
        "ios": "8.0"
    },
    "dependencies": {
        "Alamofire": [
            "~> 4.7"
        ],
        "SwiftyUserDefaults": [
            "~> 3.0.0"
        ]
    },
    "source_files": "SimpleServiceStatus/Classes/**/*"
}

Pin It on Pinterest

Share This