Latest 0.1.2
Homepage https://github.com/harushuu/SHTabbarController
License MIT
Platforms ios 8.0, requires ARC
Dependencies BFPaperButton
Frameworks UIKit
Authors

====================

License
Platform

Screenshots

Installation

With CocoaPods, add this line to your Podfile.

pod 'SHTabbarController'

and run pod install, then you’re all done!

How to use

    SHTabbarDatasourceModel *tabbarDataSource = [[SHTabbarDatasourceModel alloc] init];

    tabbarDataSource.itemsTitle = @[@"contact",  @"message"];
    tabbarDataSource.itemsImageName = @[@"contact_nor",  @"news_nor"];
    tabbarDataSource.itemsSelectedImageName = @[@"contact_selected",  @"news_selected"];
    tabbarDataSource.subControllers = @[
                                    [[yourViewController alloc] init],
                                    [[yourViewController alloc] init],
                                    ];
    tabbarDataSource.centerButtonImageName = @"centerButton";

    SHTabBarController *tabBarViewController = [SHTabBarController configureTabbarControllerWithDataSource:tabbarDataSource withDelegate:self];
    tabBarViewController.tabBar.tintColor = 'YOUR_COLOR';
    [[[[UIApplication sharedApplication] delegate] window] setRootViewController:tabBarViewController];

Requirements

  • iOS 7.0+
  • ARC

License

English: SHTabbarController is available under the MIT license, see the LICENSE file for more information.

Latest podspec

{
    "name": "SHTabbarController",
    "version": "0.1.2",
    "summary": "A simple UITabbarController with round center button.",
    "homepage": "https://github.com/harushuu/SHTabbarController",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "@harushuu": "[email protected]"
    },
    "source": {
        "git": "https://github.com/harushuu/SHTabbarController.git",
        "tag": "0.1.2"
    },
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "source_files": "SHTabbarController/*",
    "frameworks": "UIKit",
    "dependencies": {
        "BFPaperButton": [
            "~> 2.0.29"
        ]
    }
}

Pin It on Pinterest

Share This