Latest 1.1.0
Homepage https://github.com/younatics/Shader
License MIT
Platforms ios 8.0, requires ARC
Frameworks UIKit, QuartzCore
Authors

Version
Carthage Compatible
License: MIT
Platform
Swift 4.0

Intoduction

🌃 Make simple shade view with Shader!

demo
demo

Requirements

Shader is written in Swift 3. Compatible with iOS 8.0+

Installation

Cocoapods

Shader is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'Shader'

Carthage

github "younatics/Shader"

Usage

4 methods is available

// Add multiple view using tuple with cornerRadius
let shaderView = Shader.at(framesAndRadius: [(originView.frame, 50), (originView2.frame, 0)], color: UIColor.black.withAlphaComponent(0.5))

// Add common view
let shaderView = Shader.at(frame: originView.frame, color: UIColor.blue.withAlphaComponent(0.3))

// Add common view array
let shaderView = Shader.at(frames: [originView.frame, originView2.frame], color: UIColor.black.withAlphaComponent(0.5))

// Add common view and cornerRadius
let shaderView = Shader.at(frame: originView.frame, cornerRadius: 50, color: UIColor.black.withAlphaComponent(0.5))

self.view.addSubview(shaderView)

References

Please tell me or make pull request if you use this library in your application :)

Author

younatics 🇰🇷

License

Shader is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Shader",
    "version": "1.1.0",
    "summary": "Easiest way to make shade view with Swift 3",
    "description": "Easiest way to make shade view with Swift 3. You can make coachmark with this library.",
    "homepage": "https://github.com/younatics/Shader",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Seungyoun Yi": "[email protected]"
    },
    "source": {
        "git": "https://github.com/younatics/Shader.git",
        "tag": "1.1.0"
    },
    "source_files": "Shader/*.swift",
    "platforms": {
        "ios": "8.0"
    },
    "frameworks": [
        "UIKit",
        "QuartzCore"
    ],
    "requires_arc": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This