Latest 0.1.0
Homepage https://github.com/cornelltech/sdl-rkx
License MIT
Platforms ios 9.0
Dependencies ResearchKit
Authors

The Small Data Lab ResearchKit Extensions package is the easiest way to include SDL visual surveys (YADL, MEDL, PAM) into a ResearchKit application.

Requirements

  • iOS 9.0+
  • Xcode 7.3+

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

CocoaPods 1.0.0+ is required to build sdl-rkx 0.1.0+.

To integrate sdl-rkx into your Xcode project using CocoaPods, specify it in your Podfile:

platform :ios, '9.0'
use_frameworks!

pod 'sdl-rkx', '~> 0.1'

Then, run the following command:

$ pod install

NOTE: When building ResearchKit, you may need to set ‘No Common Blocks’ to ‘No’ under the Apple LLVM Code Generation heading in the ResearchKit framework Build Settings

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Author

James Kizer @ Cornell Tech Foundry

License

sdl-rkx is available under the Apache 2.0 license. See the LICENSE file for more info.

Latest podspec

{
    "name": "sdl-rkx",
    "version": "0.1.0",
    "summary": "SDL visual surveys for ResearchKit",
    "description": "The Small Data Lab ResearchKit Extensions package is the easiest way to include SDL visual surveys (YADL, MEDL, PAM) into a ResearchKit application.",
    "homepage": "https://github.com/cornelltech/sdl-rkx",
    "license": "MIT",
    "authors": {
        "James Kizer, Cornell Tech Foundry": "jdk288 at cornell dot edu"
    },
    "source": {
        "git": "https://github.com/cornelltech/sdl-rkx.git",
        "tag": "0.1.0"
    },
    "platforms": {
        "ios": "9.0"
    },
    "source_files": "sdl-rkx/Classes/**/*",
    "resources": [
        "sdl-rkx/Assets/PAM.xcassets",
        "sdl-rkx/Assets/PAM.json"
    ],
    "dependencies": {
        "ResearchKit": [
            "~> 1.3.1"
        ]
    }
}

Pin It on Pinterest

Share This