Latest 3.0
Homepage https://github.com/shamatar/scrypt-cryptoswift
License Apache License 2.0
Platforms ios 9.0, osx 10.11, requires ARC
Dependencies CryptoSwift
Authors

scrypt-cryptoswift

A description of this package.

Latest podspec

{
    "name": "scrypt",
    "version": "3.0",
    "summary": "Scrypt implementation in vanilla Swift for iOS ans macOS",
    "description": "Scrypt implementation in vanilla Swift, intended for use together with a Cryptoswift pod",
    "homepage": "https://github.com/shamatar/scrypt-cryptoswift",
    "license": "Apache License 2.0",
    "authors": {
        "Alex Vlasov": "[email protected]"
    },
    "source": {
        "git": "https://github.com/shamatar/scrypt-cryptoswift.git",
        "tag": "3.0"
    },
    "social_media_url": "https://twitter.com/shamatar",
    "swift_version": "4.2",
    "module_name": "scrypt",
    "platforms": {
        "ios": "9.0",
        "osx": "10.11"
    },
    "source_files": [
        "scrypt/Swift/*.{swift}",
        "scrypt/scrypt.h"
    ],
    "public_header_files": "scrypt/scrypt.h",
    "requires_arc": true,
    "dependencies": {
        "CryptoSwift": [
            "~> 0.13"
        ]
    },
    "pod_target_xcconfig": {
        "SWIFT_WHOLE_MODULE_OPTIMIZATION": "YES",
        "SWIFT_COMPILATION_MODE": "wholemodule",
        "SWIFT_OPTIMIZATION_LEVEL": "-Owholemodule",
        "SWIFT_DISABLE_SAFETY_CHECKS": "YES",
        "SWIFT_ENFORCE_EXCLUSIVE_ACCESS": "compile-time",
        "GCC_UNROLL_LOOPS": "YES",
        "DEFINES_MODULE": "YES"
    }
}

Pin It on Pinterest

Share This