Latest 0.9.5.1
Homepage https://github.com/artbobrov/ScrollKit
License MIT
Platforms ios 9.0, requires ARC
Authors

Build status
Platform iOSSwift 4 compatible
Carthage compatible
CocoaPods compatible
License: MIT

Introduction

ScrollKit is a library to manage your UICollectionView and UITableView data.

Usage

Look at pagination example.

Requirements

  • iOS 9.0+
  • Xcode 8.0+

Getting involved

  • If you want to contribute please feel free to submit pull requests.
  • If you have a feature request please open an issue.

Examples

Follow these 3 steps to run Example project: clone ScrollKit repository, open ScrollKit workspace and run the Example project.

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects.

To install ScrollKit, simply add the following line to your Podfile:

pod 'ScrollKit'

Carthage

Carthage is a simple, decentralized dependency manager for Cocoa.

To install ScrollKit, simply add the following line to your Cartfile:

github "artbobrov/ScrollKit"

Author

Latest podspec

{
    "name": "ScrollKit",
    "version": "0.9.5.1",
    "summary": "Easily manage your collection view and table view data.",
    "homepage": "https://github.com/artbobrov/ScrollKit",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Artem Bobrov": "[email protected]"
    },
    "source": {
        "git": "https://github.com/artbobrov/ScrollKit.git",
        "tag": "0.9.5.1"
    },
    "platforms": {
        "ios": "9.0"
    },
    "requires_arc": true,
    "ios": {
        "source_files": "Sources/**/*.{swift}",
        "frameworks": [
            "UIKit",
            "Foundation"
        ]
    }
}

Pin It on Pinterest

Share This