Latest 0.0.1
Homepage https://github.com/trilliwon/RxCoreBluetooth
License MIT
Platforms ios 10.0
Dependencies RxSwift, RxCocoa
Authors

Swift
CI Status
spm
Version
codecov
License
Platform

RxCoreBluetooth is a CoreBluetooth Extension for RxSwift


Usage

/// Bind CBManager State
centralManager.rx.state
.bind { state in
  state == .powerOn
}.disposed(by: disposeBag)

/// Bind Discovered Peripheral
centralManager.rx
.didDiscover
.bind { discovered in
  discovered
}
.disposed(by: disposeBag)

Requirements

  • iOS 10.0 +
  • Swift 3.0 +
  • Xcode 8.0 +

Installation

RxCoreBluetooth is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'RxCoreBluetooth'
– For CBCentralManager Delegates

CentralManager

– For CBPeripheral Delegates

Peripheral


Author

Won, [email protected]


License

RxCoreBluetooth is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "RxCoreBluetooth",
    "version": "0.0.1",
    "summary": "RxCoreBluetooth is a CoreBluetooth Extension for RxSwift",
    "description": "RxCoreBluetooth is a CoreBluetooth Extension for RxSwift. It contains CoreBluetoth funtionalities.",
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "3.0"
    },
    "homepage": "https://github.com/trilliwon/RxCoreBluetooth",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "trilliwon": "[email protected]"
    },
    "source": {
        "git": "https://github.com/trilliwon/RxCoreBluetooth.git",
        "tag": "0.0.1"
    },
    "social_media_url": "https://twitter.com/trilliwon",
    "platforms": {
        "ios": "10.0"
    },
    "source_files": "Sources/*",
    "dependencies": {
        "RxSwift": [
            "~> 3.0"
        ],
        "RxCocoa": [
            "~> 3.0"
        ]
    },
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This