Latest 4.0.0
Homepage https://github.com/ruslanskorb/RSKGrowingTextView
License Apache
Platforms ios 8.0, requires ARC
Dependencies RSKPlaceholderTextView
Authors

RSKGrowingTextView Swift 4.2 Cocoapods Compatible Carthage compatible

Sample

A light-weight UITextView subclass that automatically grows and shrinks based on the size of user input and can be constrained by maximum and minimum number of lines.

Installation

RSKGrowingTextView requires iOS 7.0 or later.

iOS 7

  1. Drag the code itself (.swift files) to your project. As sadly, Swift currently does not support compiling Frameworks for iOS 7.
  2. Make sure that the files are added to the Target membership.

Using CocoaPods

  1. Add the pod RSKGrowingTextView to your Podfile.

    pod 'RSKGrowingTextView'
  2. Run pod install from Terminal, then open your app’s .xcworkspace file to launch Xcode.

Using Carthage

  1. Add the ruslanskorb/RSKGrowingTextView project to your Cartfile.

    github "ruslanskorb/RSKGrowingTextView"
  2. Run carthage update, then follow the additional steps required to add the iOS and/or Mac frameworks into your project.

Demo

Build and run the RSKGrowingTextViewExample project in Xcode to see RSKGrowingTextView in action.
Have fun. Figure out hooks for customization.

Contact

Ruslan Skorb

License

This project is available under the Apache License, version 2.0. See the LICENSE file for more info.

Latest podspec

{
    "name": "RSKGrowingTextView",
    "version": "4.0.0",
    "summary": "A light-weight UITextView subclass that automatically grows and shrinks.",
    "description": "A light-weight UITextView subclass that automatically grows and shrinks based on the size of user input and can be constrained by maximum and minimum number of lines.",
    "homepage": "https://github.com/ruslanskorb/RSKGrowingTextView",
    "license": {
        "type": "Apache",
        "file": "LICENSE"
    },
    "authors": {
        "Ruslan Skorb": "[email protected]"
    },
    "source": {
        "git": "https://github.com/ruslanskorb/RSKGrowingTextView.git",
        "tag": "4.0.0"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "RSKGrowingTextView/*.{h,swift}",
    "requires_arc": true,
    "dependencies": {
        "RSKPlaceholderTextView": [
            "4.0.0"
        ]
    }
}

Pin It on Pinterest

Share This