Latest 1.1.0
Homepage https://github.com/RFUI/RFAPI
License MIT
Platforms osx 10.8, ios 7.0, requires ARC
Dependencies JSONModel, AFNetworking/NSURLConnection, RFKit/Runtime, RFKit/Category/NSDictionary, RFKit/Category/NSFileManager, RFInitializing, RFMessageManager/Manager, RFMessageManager/RFNetworkActivityIndicatorMessage
Authors

Build Status
Codecov
CocoaPods

v1 requires AFNetworking v2 and leaves here for legacy. RFAPI v2 will support AFNetworking v3.

CocoaPods Install

pod 'RFAPI'

Specify develop branch to install the lastest version:

pod 'RFMessageManager',
    :git => 'https://github.com/RFUI/RFAPI.git',
    :branch => 'develop'

Latest podspec

{
    "name": "RFAPI",
    "version": "1.1.0",
    "summary": "API Manager.",
    "homepage": "https://github.com/RFUI/RFAPI",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "BB9z": "[email protected]"
    },
    "source": {
        "git": "https://github.com/RFUI/RFAPI.git",
        "tag": "1.1.0"
    },
    "requires_arc": true,
    "platforms": {
        "osx": "10.8",
        "ios": "7.0"
    },
    "dependencies": {
        "JSONModel": [],
        "AFNetworking/NSURLConnection": [
            "~> 2.0"
        ],
        "RFKit/Runtime": [
            "> 1.7"
        ],
        "RFKit/Category/NSDictionary": [],
        "RFKit/Category/NSFileManager": [],
        "RFInitializing": [
            ">= 1.1"
        ],
        "RFMessageManager/Manager": [
            ">= 0.3"
        ],
        "RFMessageManager/RFNetworkActivityIndicatorMessage": []
    },
    "source_files": [
        "*.{h,m}",
        "RFAPIDefine/*.{h,m}"
    ],
    "public_header_files": [
        "*.h",
        "RFAPIDefine/*.h"
    ],
    "pod_target_xcconfig": {}
}

Pin It on Pinterest

Share This