Latest 0.4
Homepage https://github.com/github/Rebel
License MIT
Platforms osx 10.7, requires ARC
Frameworks QuartzCore, Cocoa, WebKit
Authors

Rebel is a framework to make AppKit easier to work with, using categories to fix bugs and make APIs nicer, and new classes to perform common tasks.

This framework is very much a work in progress at the moment, and should be considered alpha quality. Breaking changes may happen often during this time.

Getting Started

To start building the framework, clone this repository and then run script/bootstrap.
This will automatically pull down any dependencies.

When working on Rebel in isolation, use the .xcworkspace file. When integrating it into another project, use the .xcodeproj file.

License

Rebel is released under the MIT license. See LICENSE.md.

Latest podspec

{
    "name": "Rebel",
    "version": "0.4",
    "summary": "Rebel is a framework to make AppKit easier to work with.",
    "homepage": "https://github.com/github/Rebel",
    "license": {
        "type": "MIT",
        "file": "LICENSE.md"
    },
    "authors": {
        "GitHub": "[email protected]"
    },
    "source": {
        "git": "https://github.com/github/Rebel.git",
        "tag": "0.4"
    },
    "frameworks": [
        "QuartzCore",
        "Cocoa",
        "WebKit"
    ],
    "platforms": {
        "osx": "10.7"
    },
    "source_files": "Rebel/*.{h,m}",
    "exclude_files": "Rebel/NSColor+RBLCGColorAdditions.{h,m}",
    "requires_arc": true,
    "subspecs": [
        {
            "name": "NSColorExtensions",
            "source_files": "Rebel/NSColor+RBLCGColorAdditions.{h,m}",
            "requires_arc": false
        }
    ]
}

Pin It on Pinterest

Share This