Latest 1.2.0
Homepage https://github.com/iDonJose/ReactiveSwifty
License Apache 2.0
Platforms ios 8.0
Dependencies ReactiveSwift
Frameworks Foundation
Authors

Overloads ReactiveSwift for better streaming of values, allowing for high productivity.


ReactiveSwifty


ReactiveSwifty


ReactiveSwifty


ReactiveSwifty

🎲 Playground

Jump to the included Playground to get a quick hint of what this framework can do !

ReactiveSwifty

  1. Clone this repository.
  2. Install pods with $ pod install
  3. Open ReactiveSwifty.xcworkspace
  4. Build ReactiveSwifty-iOS scheme with an iOS Simulator
  5. Open Playground.playground
  6. Run Playground !

🛠 Installation

CocoaPods

If you are using CocoaPods as a dependency manager, add this one line to your Podfile:

pod 'ReactiveSwifty'

And update your pods with this command:

$ pod install

Manually

To add ReactiveSwifty to your project manually, download the source code and place it in your project directory.

👋 Contributing

  1. Fork this repository.
  2. Create a feature branch (git checkout -b feature/myFeature)
  3. Commit the changes (git commit -am 'Add my new feature')
  4. Push to the branch (git push origin feature/myFeature)
  5. Create a new Pull Request

✍️ Authors

ReactiveSwifty was created and is still maintained by José Donor.

👏 Greetings

ReactiveSwifty was made possible thanks to :

📃 License

ReactiveSwifty is released under an Apache 2.0 license. See License for more information.

Latest podspec

{
    "name": "ReactiveSwifty",
    "version": "1.2.0",
    "summary": "Enhances streams of values provided by ReactiveSwift",
    "description": "Overloads `ReactiveSwift` for better streaming of values, allowing for high productivity.",
    "homepage": "https://github.com/iDonJose/ReactiveSwifty",
    "source": {
        "git": "https://github.com/iDonJose/ReactiveSwifty.git",
        "tag": "1.2.0"
    },
    "license": {
        "type": "Apache 2.0",
        "file": "LICENSE"
    },
    "authors": {
        "iDonJose": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "Sources/**/*.{h,swift}",
    "frameworks": "Foundation",
    "dependencies": {
        "ReactiveSwift": [
            "~> 4.0"
        ]
    }
}

Pin It on Pinterest

Share This