Latest 0.1.0
Homepage https://github.com/Clawiste/ReactiveCocoa-NSExtensions
License MIT
Platforms osx 10.9
Dependencies ReactiveCocoa
Authors

[![CI Status](http://img.shields.io/travis/Jan Prokeš/ReactiveCocoa-NSExtensions.svg?style=flat)](https://travis-ci.org/Jan Prokeš/ReactiveCocoa-NSExtensions)
Version
License
Platform
Carthage compatible

NSExtensions extends ReactiveCocoa UI Bindings for macOS elements

Extended Elements

  • NSButton
    • title
    • alternativeTitle
  • NSDatePicker
    • dateValue
    • timeInterval
  • NSImageView
    • image
  • NSSegmentedControl
    • selectedSegment
  • NSView
    • alphaValue
    • isHidden

Installation

ReactiveCocoa-NSExtensions is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "ReactiveCocoa-NSExtensions"

is also available through Carthage. To install it, simply add the following line to your Cartfile:

github "Clawiste/ReactiveCocoa-NSExtensions"

Have a question/request?

If you need any help, please visit GitHub issues or contact me at twitter. Feel free to file an issue if you do not manage to find any solution from the archives.

Author

Jan Prokeš, [email protected]

License

ReactiveCocoa-NSExtensions is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "ReactiveCocoa-NSExtensions",
    "version": "0.1.0",
    "summary": "Extends ReactiveCocoa UI Bindings for macOS.",
    "description": "NSExtensions extends ReactiveCocoa UI Bindings for macOS elements. Extends elements as u2013 NSButton, NSDatePicker, NSImageView, NSSegmentedControl, NSView",
    "homepage": "https://github.com/Clawiste/ReactiveCocoa-NSExtensions",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Jan Prokesu030c": "[email protected]"
    },
    "platforms": {
        "osx": "10.9"
    },
    "source": {
        "git": "https://github.com/Clawiste/ReactiveCocoa-NSExtensions.git",
        "tag": "0.1.0"
    },
    "social_media_url": "https://twitter.com/Clawiste",
    "source_files": "ReactiveCocoa NSExtensions/*.swift",
    "dependencies": {
        "ReactiveCocoa": [
            "~> 5.0"
        ]
    },
    "pushed_with_swift_version": "3.0.2"
}

Pin It on Pinterest

Share This