Latest 2.6.2
Homepage https://github.com/lionheart/QuickTableView
License Apache 2.0
Platforms ios 10.3, requires ARC
Frameworks UIKit
Authors


CI Status
Version
License
Platform

QuickTableView is a toolset to make interacting with UITableView in Swift fast and easy. If you’ve ever dreaded writing the boilerplate required to make even the simplest tableview, you’re going to love it.

QuickTableView uses Semantic Versioning.

Please read the documentation for more information.

What’s Included

  • [x] UITableViewCell subclasses for common cell types, with built-in Auto Layout support.
  • [x] A drop-in replacement for UITableViewController that automatically updates constraints based on keyboard appearance.
  • [x] A clean, enum-based approach that greatly simplifies UITableView row and section management.
  • [x] Much, much more!

Usage

To run the example project, clone the repo, and run pod install from the Example directory first.

Installation

QuickTableView is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "QuickTableView"

Author

Dan Loewenherz, [email protected]

License

QuickTableView is available under the Apache 2.0 license. See the LICENSE file for more info.


Latest podspec

{
    "name": "QuickTableView",
    "version": "2.6.2",
    "summary": "Helper classes and utilities that help speed up tableview creation and management in Swift.",
    "description": "QuickTableView provides two helper classes, SimpleTableViewController and BaseTableViewController, that drastically simplify table view creation in Swift.",
    "homepage": "https://github.com/lionheart/QuickTableView",
    "license": "Apache 2.0",
    "authors": {
        "Dan Loewenherz": "[email protected]"
    },
    "source": {
        "git": "https://github.com/lionheart/QuickTableView.git",
        "tag": "2.6.2"
    },
    "social_media_url": "https://twitter.com/lionheartsw",
    "platforms": {
        "ios": "10.3"
    },
    "swift_version": "4.0",
    "requires_arc": true,
    "source_files": [
        "Pod/Classes/**/*",
        "Pod/Extensions/**/*",
        "Pod/Protocols/**/*"
    ],
    "frameworks": "UIKit",
    "ios": {
        "dependencies": {
            "KeyboardAdjuster": [
                "~> 3"
            ]
        }
    }
}

Pin It on Pinterest

Share This