Latest0.6.5
Homepagehttps://github.com/quickbirdstudios/QBRepository
LicenseMIT
Platformsios 8.0
Authors

CI Status
Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

QBRepository is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'QBRepository'

Author

Stefan Kofler, [email protected]

License

QBRepository is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "QBRepository",
    "version": "0.6.5",
    "summary": "QBRepository is a simple implementation of the repository pattern for data access in Swift.",
    "description": "QBRepository is a simple implementation of the repository pattern for data access in Swift, with a default wrapper for Realm und reactive extensions for RxSwift.",
    "homepage": "https://github.com/quickbirdstudios/QBRepository",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Stefan Kofler": "[email protected]"
    },
    "source": {
        "git": "https://github.com/quickbirdstudios/QBRepository.git",
        "tag": "0.6.5"
    },
    "platforms": {
        "ios": "8.0"
    },
    "swift_version": "4.0",
    "default_subspecs": "Core",
    "subspecs": [
        {
            "name": "Core",
            "source_files": "Sources/*.swift",
            "frameworks": "Foundation"
        },
        {
            "name": "Realm",
            "source_files": "Sources/Realm/*.swift",
            "dependencies": {
                "QBRepository/Core": [],
                "RealmSwift": [
                    "~> 3.0"
                ]
            }
        },
        {
            "name": "FileSystem",
            "source_files": "Sources/FileSystem/*.swift",
            "dependencies": {
                "QBRepository/Core": []
            }
        },
        {
            "name": "CoreData",
            "source_files": "Sources/CoreData/*.swift",
            "dependencies": {
                "QBRepository/Core": []
            }
        },
        {
            "name": "RxSwift",
            "source_files": "Sources/RxSwift/*.swift",
            "dependencies": {
                "QBRepository/Core": [],
                "RxSwift": [
                    "~> 4.0"
                ]
            }
        }
    ]
}

Pin It on Pinterest

Share This