Latest 0.1
Homepage https://github.com/shomishinec/PrettySegue
License MIT
Platforms ios 8.0
Frameworks UIKit
Authors

Storyboard segues with closures

BuddyBuild
Version
License
Platform

Requirements

  • iOS 8.0+
  • Xcode 8.2.1 +
  • Swift 3.0+

Installation

PrettySegue is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "PrettySegue"

Usage

If you create a segue in storyboard named "area", you can perfrom the segue like this:

import PrettySegue

class ViewController: UIViewController {

    // basic
    @IBAction func onBtnA(sender: AnyObject) {
       performSegue(withIdentifier: "area", sender: self) { (areaVC: AreaViewController) in
                areaVC.height = 10
                areaVC.width = 10
          }
    }
}

License

PrettySegue is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "PrettySegue",
    "version": "0.1",
    "summary": "Pretty Storyboard segues with closures.",
    "homepage": "https://github.com/shomishinec/PrettySegue",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Stan H": "[email protected]"
    },
    "source": {
        "git": "https://github.com/shomishinec/PrettySegue.git",
        "tag": "0.1"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "Source/*.swift",
    "frameworks": "UIKit",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This